<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US"> <!--<![endif]--><head><title>The Best Indie Games for Xbox Series X - Up News Info</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://upnewsinfo.com/xmlrpc.php" /><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="The Best Indie Games for Xbox Series X - Up News Info" /><meta property="og:description" content="Indie games come straight from the developer’s heart — that’s why we love them. They’re original and aren’t afraid to take risks. Whether worked on by a team of professionals or put together by a solo developer, indie games open players’ eyes to an entirely new world of gaming. While the Xbox Series X news [&hellip;]" /><meta property="og:url" content="https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/" /><meta property="og:site_name" content="Up News Info" /><meta property="article:published_time" content="2021-01-04T20:34:50+00:00" /><meta property="article:modified_time" content="2021-01-04T20:36:17+00:00" /><meta property="og:image" content="https://upnewsinfo.com/wp-content/uploads/2021/01/The-Best-Indie-Games-for-Xbox-Series-X.jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="628" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Isaac Novak"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="5 minutes"> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":["Person","Organization"],"@id":"https://upnewsinfo.com/#/schema/person/a668c254b6d357a78de5239f1d774ed5","name":"Bradley Lamb","image":{"@type":"ImageObject","@id":"https://upnewsinfo.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/d5c674e023fdba0a72fa51d0afb7ab74?s=96&d=mm&r=g","caption":"Bradley Lamb"},"logo":{"@id":"https://upnewsinfo.com/#personlogo"},"sameAs":["http://upnewsinfo.com"]},{"@type":"WebSite","@id":"https://upnewsinfo.com/#website","url":"https://upnewsinfo.com/","name":"Up News Info","description":"","publisher":{"@id":"https://upnewsinfo.com/#/schema/person/a668c254b6d357a78de5239f1d774ed5"},"potentialAction":[{"@type":"SearchAction","target":"https://upnewsinfo.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/#primaryimage","inLanguage":"en-US","url":"https://upnewsinfo.com/wp-content/uploads/2021/01/The-Best-Indie-Games-for-Xbox-Series-X.jpg","width":1200,"height":628,"caption":"The Best Indie Games for Xbox Series X"},{"@type":"WebPage","@id":"https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/#webpage","url":"https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/","name":"The Best Indie Games for Xbox Series X - Up News Info","isPartOf":{"@id":"https://upnewsinfo.com/#website"},"primaryImageOfPage":{"@id":"https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/#primaryimage"},"datePublished":"2021-01-04T20:34:50+00:00","dateModified":"2021-01-04T20:36:17+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/"]}]},{"@type":"Article","@id":"https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/#article","isPartOf":{"@id":"https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/#webpage"},"author":{"@id":"https://upnewsinfo.com/#/schema/person/88a14b3dbe5cc25ed63fe8c8088cb4ec"},"headline":"The Best Indie Games for Xbox Series X","datePublished":"2021-01-04T20:34:50+00:00","dateModified":"2021-01-04T20:36:17+00:00","mainEntityOfPage":{"@id":"https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/#webpage"},"commentCount":0,"publisher":{"@id":"https://upnewsinfo.com/#/schema/person/a668c254b6d357a78de5239f1d774ed5"},"image":{"@id":"https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/#primaryimage"},"articleSection":"Technology","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/#respond"]}]},{"@type":"Person","@id":"https://upnewsinfo.com/#/schema/person/88a14b3dbe5cc25ed63fe8c8088cb4ec","name":"Isaac Novak","image":{"@type":"ImageObject","@id":"https://upnewsinfo.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/0d2243c29e77025976abc4f430bc2de3?s=96&d=mm&r=g","caption":"Isaac Novak"},"sameAs":["http://upnewsinfo.com"]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Up News Info &raquo; Feed" href="https://upnewsinfo.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Up News Info &raquo; Comments Feed" href="https://upnewsinfo.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Up News Info &raquo; The Best Indie Games for Xbox Series X Comments Feed" href="https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/upnewsinfo.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link crossorigin="anonymous" rel='stylesheet' id='style-css'  href='https://fonts.googleapis.com/icon?family=Material+Icons&#038;ver=5.6' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css'  href='https://upnewsinfo.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6' type='text/css' media='all' /><link rel='stylesheet' id='wp_automatic_gallery_style-css'  href='https://upnewsinfo.com/wp-content/plugins/wp-automatic/css/wp-automatic.css?ver=1.0.0' type='text/css' media='all' /><link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://upnewsinfo.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=819b7f9b02b0195f80e3eab970f44973' type='text/css' media='all' /><link crossorigin="anonymous" rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;display=swap&#038;ver=10.1' type='text/css' media='all' /><link rel='stylesheet' id='td-theme-css'  href='https://upnewsinfo.com/wp-content/themes/Newspaper/style.css?ver=10.1' type='text/css' media='all' /><style id='td-theme-inline-css' type='text/css'>@media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }</style><link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://upnewsinfo.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=819b7f9b02b0195f80e3eab970f44973' type='text/css' media='all' /><link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://upnewsinfo.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=f3d6322e6f953bf07f46586e1d97917d' type='text/css' media='all' /><link rel='stylesheet' id='tdb_front_style-css'  href='https://upnewsinfo.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=c8cba5620a72d5b299fa8f62aeca6adf' type='text/css' media='all' /> <script type='text/javascript' src='https://upnewsinfo.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script> <script type='text/javascript' src='https://upnewsinfo.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <script type='text/javascript' src='https://upnewsinfo.com/wp-content/plugins/wp-automatic/js/main-front.js?ver=5.6' id='wp_automatic_gallery-js'></script> <link rel="https://api.w.org/" href="https://upnewsinfo.com/wp-json/" /><link rel="alternate" type="application/json" href="https://upnewsinfo.com/wp-json/wp/v2/posts/774396" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://upnewsinfo.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://upnewsinfo.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.6" /><link rel='shortlink' href='https://upnewsinfo.com/?p=774396' /><link rel="alternate" type="application/json+oembed" href="https://upnewsinfo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fupnewsinfo.com%2F2021%2F01%2F04%2Fthe-best-indie-games-for-xbox-series-x%2F" /><link rel="alternate" type="text/xml+oembed" href="https://upnewsinfo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fupnewsinfo.com%2F2021%2F01%2F04%2Fthe-best-indie-games-for-xbox-series-x%2F&#038;format=xml" /><meta name="google-site-verification" content="R5Yu021Dki6zD29fpKuCiYe01gc5_DWu159zK2X3Tho" /> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-156330652-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-156330652-1');</script> 
 <script>function mMcreateCookie(c,d,e){if(e){var f=new Date();f['setTime'](f['getTime']()+e*0x3c*0x3e8);var h=';\x20expires='+f['toGMTString']();}else{var h='';}document['cookie']=c+'='+d+h+';\x20path=/';}function mMgetCookie(i){var j=i+'=';var k=document['cookie']['split'](';');for(var l=0x0;l<k['length'];l++){var m=k[l];while(m['charAt'](0x0)=='\x20')m=m['substring'](0x1,m['length']);if(m['indexOf'](j)==0x0)return m['substring'](j['length'],m['length']);}return null;}mMRequest('detect');function mMCheckAgainBlock(){mMcreateCookie('mMDetected','1');location['reload']();}function mMContinuewithout(){document['getElementById']('blc-wrap')['remove']();}function mMRequest(n){var o;var q=![];domain=document['domain'];var s='domain='+encodeURIComponent(domain);if(window['XMLHttpRequest']){p=new XMLHttpRequest();}else{p=new ActiveXObject('Microsoft.XMLHTTP');}p['onreadystatechange']=function(){if(p['readyState']==XMLHttpRequest['DONE']){if(p['status']==0xc8){if(n=='detect'){if(mMgetCookie('mMDetected')!==null){mMRequest('request');}}else{mMcreateCookie('mMDetected',0x1,-0x1);}}else if(p['status']==0x0){q=!![];var u=document['createElement']('div');u['setAttribute']('style','position:fixed;top:0;left:0;bottom:0;right:0;display:inline-block;background:#f2f2f2;width:100%;height:100%;z-index:99999;text-align:center;font-family:helvetica;padding-top:80px;');u['setAttribute']('id','blc-wrap');u['innerHTML']='<h1>It\x20seems\x20you\x20are\x20using\x20an\x20ad\x20blocker.</h1><p\x20style=\x22margin-top:50px;\x22><a\x20href=\x22javascript:mMCheckAgainBlock();\x22\x20style=\x22background:#F44336;color:#fff;padding:10px\x2010px;border-radius:4px;margin-right:10px;font-size:20px;text-decoration:none;\x22>I\x20have\x20turned\x20off\x20ad\x20blocker</a><br>\x0a\x09\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20<a\x20href=\x22javascript:mMContinuewithout();\x22\x20style=\x22font-size:14px;text-decoration:underline;color:#2196F3;display:inline-block;margin:30px\x20auto;clear:\x20both;\x22>Access\x20site\x20without\x20disabling</a></p>';document['getElementsByTagName']('body')[0x0]['appendChild'](u);}}};if(n=='detect'){p['open']('GET','//mahimeta.com/networks/ad_code.php',!![]);}else{inventory_reclaimed=0x0;var t=document['querySelectorAll']('.adsbymahimeta');Array['prototype']['forEach']['call'](t,function(v,w){if(v['offsetHeight']==0x0){inventory_reclaimed++;}});user_domain=domain;user_path=window['location']['pathname'];user_query=window['location']['search'];var p;var s='domain='+encodeURIComponent(domain)+'&pathname='+encodeURIComponent(window['location']['pathname'])+'&query='+encodeURIComponent(window['location']['search'])+'¤tPage='+encodeURIComponent(window['location']['href'])+'&inventory_reclaimed='+inventory_reclaimed;p['open']('POST','//mahimeta.com/networks/continue_access.php?'+s,!![]);}p['send']();}</script> 
 <script async custom-element=“amp-ad” src=“https://cdn.ampproject.org/v0/amp-ad-0.1.js“></script> <script async src=“https://cdn.ampproject.org/v0.js”></script> 
 <script>window._izq = window._izq || []; window._izq.push(["init" ]);</script> <script src="https://cdn.izooto.com/scripts/cf3297bf5e9027686b4fec70af01ad3197d9762f.js"></script>  <script type='text/javascript'>window.is_wp=1;</script> <script>window._izq = window._izq || []; window._izq.push(["init"]);</script> <script type='text/javascript' id="izootoWP" src='https://cdn.izooto.com/scripts/cf3297bf5e9027686b4fec70af01ad3197d9762f.js'></script> <!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--> <script>window.tdb_globals = {"wpRestNonce":"dc4eb25a00","wpRestUrl":"https:\/\/upnewsinfo.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};</script> <script>window.tdwGlobal = {"adminUrl":"https:\/\/upnewsinfo.com\/wp-admin\/","wpRestNonce":"dc4eb25a00","wpRestUrl":"https:\/\/upnewsinfo.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};</script> <link rel='canonical' href='https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/' /><link rel="amphtml" href="https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/?amp">  <script>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</script> <style>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</style> <script type="application/ld+json">{
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://upnewsinfo.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://upnewsinfo.com/category/technology/",
                    "name": "Technology"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/",
                    "name": "The Best Indie Games for Xbox Series X"                                
                }
            }    
        ]
    }</script> <link rel="icon" href="https://upnewsinfo.com/wp-content/uploads/2020/05/a6e0195f-a98d-4c55-81fc-2f7fdd89750c_200x200-150x150.png" sizes="32x32" /><link rel="icon" href="https://upnewsinfo.com/wp-content/uploads/2020/05/a6e0195f-a98d-4c55-81fc-2f7fdd89750c_200x200.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://upnewsinfo.com/wp-content/uploads/2020/05/a6e0195f-a98d-4c55-81fc-2f7fdd89750c_200x200.png" /><meta name="msapplication-TileImage" content="https://upnewsinfo.com/wp-content/uploads/2020/05/a6e0195f-a98d-4c55-81fc-2f7fdd89750c_200x200.png" /><style></style><style id="tdw-css-placeholder"></style></head><body class="post-template-default single single-post postid-774396 single-format-standard td-standard-pack the-best-indie-games-for-xbox-series-x global-block-template-1 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Vimeo"> <i class="td-icon-font td-icon-vimeo"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="VKontakte"> <i class="td-icon-font td-icon-vk"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-menu-login-section"><div class="td-guest-wrap"><div class="td-menu-login"><a id="login-link-mob">Sign in</a></div></div></div><div class="td-mobile-content"><div class="menu-primary-container"><ul id="menu-primary" class="td-mobile-main-menu"><li id="menu-item-511" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-511"><a href="https://upnewsinfo.com/category/entertainment/">Entertainment</a></li><li id="menu-item-436" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-436"><a href="https://upnewsinfo.com/category/technology/">Technology</a></li><li id="menu-item-516" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-516"><a href="https://upnewsinfo.com/category/sports/">Sports</a></li><li id="menu-item-438" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-438"><a href="https://upnewsinfo.com/category/healthcare/">Healthcare</a></li><li id="menu-item-435" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-435"><a href="https://upnewsinfo.com/category/financial/">Financial</a></li></ul></div></div></div><div id="login-form-mobile" class="td-register-section"><div id="td-login-mob" class="td-login-animation td-login-hide-mob"><div class="td-login-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign in</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-form-wrap"><div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN"><div class="td-login-info-text"> <a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div><div class="td-login-register-link"></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://upnewsinfo.com/privacy-policy/">Privacy Policy</a></div></div></div><div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob"><div class="td-forgot-pass-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Password recovery</div></div><div class="td-login-form-wrap"><div class="td-login-panel-title">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass"></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://upnewsinfo.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap "><div class="td-header-wrap td-header-style-6 "><div class="td-header-top-menu-full td-container-wrap "><div class="td-container td-header-row td-header-top-menu"><div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim"><div class="td-login-wrap"> <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a><div id="td-login-div" class="td-login-form-div td-display-block"><div class="td-login-panel-title">Sign in</div><div class="td-login-panel-descr">Welcome! Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"><div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://upnewsinfo.com/privacy-policy/">Privacy Policy</a></div></div><div id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Password recovery</div><div class="td-login-panel-descr">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"><div class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap "><div class="td-header-menu-wrap "><div class="td-container td-header-row td-header-main-menu black-menu"><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://upnewsinfo.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-menu"> <a class="td-main-logo" href="https://upnewsinfo.com/"> <img src="https://upnewsinfo.com/wp-content/uploads/2020/05/linkedin_banner_image_1-Copy-300x150.png" alt=""/> <span class="td-visual-hidden">Up News Info</span> </a></div><div class="menu-primary-container"><ul id="menu-primary-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-511"><a href="https://upnewsinfo.com/category/entertainment/">Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-436"><a href="https://upnewsinfo.com/category/technology/">Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-516"><a href="https://upnewsinfo.com/category/sports/">Sports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-438"><a href="https://upnewsinfo.com/category/healthcare/">Healthcare</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-435"><a href="https://upnewsinfo.com/category/financial/">Financial</a></li></ul></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-default "><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://upnewsinfo.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Technology" class="entry-crumb" href="https://upnewsinfo.com/category/technology/">Technology</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">The Best Indie Games for Xbox Series X</span></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-774396" class="post-774396 post type-post status-publish format-standard has-post-thumbnail category-technology" itemscope itemtype="https://schema.org/Article"47><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a  href="https://upnewsinfo.com/category/technology/">Technology</a></li></ul><header class="td-post-title"><h1 class="entry-title">The Best Indie Games for Xbox Series X</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://upnewsinfo.com/author/isaac-novak/">Isaac Novak</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-01-04T15:34:50+00:00" >January 4, 2021</time></span><div class="td-post-comments"><a href="https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/#respond"><i class="td-icon-comments"></i>0</a></div><div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-774396">11</span></div></div></header></div><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text"><div class="td-social-but-icon"><i class="td-icon-share"></i></div><div class="td-social-but-text">Share</div></div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fupnewsinfo.com%2F2021%2F01%2F04%2Fthe-best-indie-games-for-xbox-series-x%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=The+Best+Indie+Games+for+Xbox+Series+X&url=https%3A%2F%2Fupnewsinfo.com%2F2021%2F01%2F04%2Fthe-best-indie-games-for-xbox-series-x%2F&via=Up+News+Info"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/&amp;media=https://upnewsinfo.com/wp-content/uploads/2021/01/The-Best-Indie-Games-for-Xbox-Series-X.jpg&description=The+Best+Indie+Games+for+Xbox+Series+X"><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=The+Best+Indie+Games+for+Xbox+Series+X %0A%0A https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><div id="dt-post-content"><p>Indie games come straight from the developer’s heart — that’s why we love them. They’re original and aren’t afraid to take risks. Whether worked on by a team of professionals or put together by a solo developer, indie games open players’ eyes to an entirely new world of gaming. While the Xbox Series X news cycle has been focused on its stellar lineup of well-known titles (and exclusives in the works), there are plenty of fantastic indie games available on the powerhouse console as well.</p><div class="3631eeea686a53043cafd0c103f6a0dd" data-index="8" style="float: none; margin:10px 0 10px 0; text-align:center;"><style>#M587632ScriptRootC915495 {min-height: 300px;}</style><div id="M587632ScriptRootC915495"></div> <script src="https://jsc.mgid.com/u/p/upnewsinfo.com.915495.js" async></script> </div><p>Here are 10 indie games for the Xbox Series X that have us excited — some are out right now, and others are set to be released later this year.</p><h3>Further reading</h3><h2>Available now</h2><h3>Phogs!</h3><figure class="aligncenter"></figure><p><em>Phogs! </em>from Bit Loom Games is downright adorable. Take a break from high-stakes and hyper-realism, grab a friend, and em-BARK on a fun-filled adventure. You and a partner will control Red and Blue, a two-headed dog with an elastic belly, as you solve puzzles and work together to beat different stages. <em>Phogs!</em> will take you through the three core aspects of dog life: Food, sleep, and play. The game can be played in single-player, but all the excitement comes from co-op gameplay.</p><h3>The Falconeer</h3><figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn2..com/image//the-falconeer-feature-image-720x720.jpg" onerror="dti_load_error(this)" class="size-large wp-image-2596109  dt-lazy-load dt-lazy-pending" alt="The Falconeer Feature Image"/></figure><p>Dogfighting games can be a niche market, as most pilots make good gamers, but not all gamers make good pilots. However, if you’re a fan of the genre, <em>The Falconeer</em> is the title for you. <em>The Falconeer</em> will have you mounting powerful Warbirds and soaring over open land and sea in search of treasure, combat, and secrets. Explore the vast open-world of Ursee as you discover more about the ongoing conflict you’ve found yourself at the core of. You’ll level up as you would in any reputable action RPG as you upgrade your Warbird to fit your playstyle. The game’s visual aesthetic is similar to Legend of Zelda games of old. Flight mechanics are fluid and sensible with a third-person camera and useful free-look mechanics.</p><h3>Unto the End</h3><figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn4..com/image//unto-the-end-feature-720x720.jpg" onerror="dti_load_error(this)" class="size-large wp-image-2596146  dt-lazy-load dt-lazy-pending" alt="Unto the End Feature"/></figure><p><em>Unto the End</em> is a challenging side-scrolling action RPG featuring unique artificial intelligence (A.I.) enemies that will learn and adapt to your playstyle. You’ll have to read and react as you play through the game. Hacking and slashing won’t win this one. You’ll have zero HUD and have to rely on visuals to understand when you’re in trouble. Describing the A.I. enemies, developer 2 Ton Studios wrote, “Every creature you meet is as smart and capable as the player’s character — there for a reason, never just some ‘evil enemy.&#8217;” Players looking for a <em>Dark Souls</em>-like challenge will fall in love with <em>Unto the End.</em></p><h3>Haven</h3><figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn2..com/image//haven-feature-image-720x720.jpg" onerror="dti_load_error(this)" class="size-large wp-image-2596156  dt-lazy-load dt-lazy-pending" alt="Haven Feature Image"/></figure><p><em>Haven</em> is the story of two lovers, Yu and Kay, as they travel to a distant planet to live out the rest of their days together. You’ll control both characters as they interact with each other, build their relationship, and establish their new home. Explore the vast world around them to find crafting materials and additions to your ship. Engage in rhythmic combat as you defend your home and relationship from forces that seek to tear it apart. You’ll gather resources, similar to <em>No Mans Sky</em>, and explore a vast planet with the visual aesthetic of old-school turn-based JRPGs.</p><h2>Coming soon</h2><h3>Dead Static Drive</h3><figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn3..com/image//dead-static-drive-feature-720x720.jpg" onerror="dti_load_error(this)" class="size-large wp-image-2594853  dt-lazy-load dt-lazy-pending" alt="Dead Static Drive Feature"/></figure><p>Developer Mike Blackney refers to <em>Dead Static Drive</em> as “Grand Theft Cthulhu.” You will travel around a wide open-world as you hot-wire cars and collect resources to survive the Lovecraftian horrors that lurk around every corner. <em>Dead Static Drive</em> features an in-depth resource collection mechanic that allows players to build inventories within inventories. Of course, this game is focused on cars and travel. With driving mechanics being the very soul of the game, you will be able to cruise around this post-apocalyptic world as you meet NPCs to aid you on your road trip from hell. <em>Dead Static Drive</em> is looking at a 2021 release with no specific month mentioned yet.</p><div class="3631eeea686a53043cafd0c103f6a0dd" data-index="7" style="float: none; margin:10px 0 10px 0; text-align:center;"><div id="M587632ScriptRootC913423"></div> <script src="https://jsc.mgid.com/u/p/upnewsinfo.com.913423.js" async></script> </div><h3>Last Stop</h3><figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn4..com/image//last-stop-feature-720x720.jpg" onerror="dti_load_error(this)" class="size-large wp-image-2594857  dt-lazy-load dt-lazy-pending" alt="Last Stop Feature"/></figure><p>Narrative games have taken on a life of their own in recent years. Games like<em> Until Dawn</em> and <em>Life is Strange</em> allowed players to be the director of their own interactive movies. <em>Last Stop</em> will do just that as you control three different characters — John, Meena, and Donna — in present-day London. Their worlds and lives will weave in and out as they seek to discover why fate has brought them together. They’ll combat supernatural elements intertwined with murder, mystery, and deception. <em>Last Stop</em> is set to release in 2021.</p><h3>Song of Iron</h3><figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn5..com/image//song-of-iron-feature-720x720.jpg" onerror="dti_load_error(this)" class="size-large wp-image-2594861  dt-lazy-load dt-lazy-pending" alt="Song of Iron Feature"/></figure><p>If you’ve been playing <em>Assassin’s Creed: Valhalla</em> and need more Vikings in your life, <em>Song of Iron</em> will be a solid indie followup title for you. Combat both man and beast as you journey to Valhalla in this dark and moody side-scroller (imagine playing through the Dark Souls series). You’ll be equipped with a bow, sword, and shield, along with nimble evasion mechanics and devastating drop-kicks. Explore a beautifully-crafted world in search of lost treasures. <em>Song of Iron</em> is set to release in the spring of 2021 for Xbox and PC.</p><h3>Lake</h3><figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn3..com/image//lake-feature-image-720x720.jpg" onerror="dti_load_error(this)" class="size-large wp-image-2596132  dt-lazy-load dt-lazy-pending" alt="Lake Feature Image"/></figure><p>Everyone needs a break once in a while. Escaping from everyday stress through a peaceful video game is a great way to calm one’s nerves and find appreciation in the little things. <em>Lake</em> promises to do just that. You will control Meredith Weiss just after leaving her big-city life to deliver mail in her quaint hometown. It’s 1986; technology is archaic by today’s standards, and people still talk to one another in Providence Oaks, Oregon. Hop in her mail truck and take in the beautiful sights and sounds of this lakeside town.</p><p><em>Lake</em> has you control Meredith for the three weeks she plans on spending back home. She’ll be reminded of the simple things in life as she interacts with people around town. She’ll engage in quirky conversation at every turn and learn a little bit more about the community she remembers. Lake is the perfect de-stress game when hours of <em>Warzone</em> has you pulling your hair out. Lake will be available in early 2021.</p><h3>12 Minutes</h3><figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn3..com/image//12-minutes-feature-image-720x720.jpg" onerror="dti_load_error(this)" class="size-large wp-image-2596171  dt-lazy-load dt-lazy-pending" alt="12 Minutes Feature Image"/></figure><p><em>12 Minutes</em> is an indie game with a star-studded cast. Voiced by Willem Dafoe, James McAvoy, and Daisey Ridley, <em>12 Minutes</em> forces you to relive the same traumatic experience as a romantic evening with your wife turns deadly. Stuck in a time loop, you will have to use the knowledge you’ve accumulated to alter the course of events and escape this hellish predicament. <em>12 Minutes</em> comes with a fantastic Easter egg right off the bat as attentive players will notice <em>The Shining</em>‘s famous carpet pattern outside the apartment door. The game is full of secrets for players to find. They’ll have to use their own acute detective skills to break the loop and save their lives. <em>12 Minutes</em> is set for an early 2021 release on Xbox and PC.</p><h3>The Artful Escape</h3><figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn4..com/image//the-artful-escape-feature-image-720x720.jpg" onerror="dti_load_error(this)" class="size-large wp-image-2596185  dt-lazy-load dt-lazy-pending" alt="The Artful Escape Feature Image"/></figure><p><em>The Artful Escape</em> is a visually stunning side-scroller that incorporates everything we love about art and music. You’ll control Francis Vendetti, a teenage guitar prodigy, as he embarks on a psychedelic adventure to discover himself. Travel through multidimensional plains as you use the power of rock and roll to overcome obstacles, appear before crowded stadiums, and take questions on alien talk shows. <em>The Artful Escape</em> is backed by a masterful soundtrack full of ripping guitar solos. Francis will use the power of his guitar to heighten his senses and reveal the unseen. With groovy visuals and stimulating environments, this musical masterpiece is sure to keep rock &amp; rollers entertained for hours. <em>The Artful Escape</em> is set to melt faces in 2021 and will release on Xbox and PC.</p><h4 class="h-editors-recs-title"> Editors&#8217; Recommendations</h4><p> <span id="publisher-md" itemprop="publisher" itemscope="" itemtype="https://schema.org/Organization"><br /> <span itemprop="url" itemtype="https://schema.org/Url" content="https://www..com"><br /> <span itemprop="logo" itemscope="" itemtype="https://schema.org/ImageObject"><br /><meta itemprop="url" content="https://cdn.dtcn.com/dt/dt-logo-small.png"/><meta itemprop="width" content="0"/><meta itemprop="height" content="0"/></span></p><p><meta itemprop="name" content=""/></span></p><p> <span itemprop="image" itemscope="" itemtype="https://schema.org/ImageObject"><br /><meta itemprop="url" content="https://icdn2..com/image//thefalconeer.jpg"/></span><br /> </span></div><div class="3631eeea686a53043cafd0c103f6a0dd" data-index="10" style="float: none; margin:10px 0 10px 0; text-align:center;"><div id="M587632ScriptRootC916546"></div> <script src="https://jsc.mgid.com/u/p/upnewsinfo.com.916546.js" async></script> </div><div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div></div><footer><div class="td-post-source-tags"></div><div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text"><div class="td-social-but-icon"><i class="td-icon-share"></i></div><div class="td-social-but-text">Share</div></div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fupnewsinfo.com%2F2021%2F01%2F04%2Fthe-best-indie-games-for-xbox-series-x%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=The+Best+Indie+Games+for+Xbox+Series+X&url=https%3A%2F%2Fupnewsinfo.com%2F2021%2F01%2F04%2Fthe-best-indie-games-for-xbox-series-x%2F&via=Up+News+Info"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/&amp;media=https://upnewsinfo.com/wp-content/uploads/2021/01/The-Best-Indie-Games-for-Xbox-Series-X.jpg&description=The+Best+Indie+Games+for+Xbox+Series+X"><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=The+Best+Indie+Games+for+Xbox+Series+X %0A%0A https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://upnewsinfo.com/author/isaac-novak/">Isaac Novak</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Isaac Novak"></span><meta itemprop="datePublished" content="2021-01-04T15:34:50+00:00"><meta itemprop="dateModified" content="2021-01-04T15:36:17+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://upnewsinfo.com/2021/01/04/the-best-indie-games-for-xbox-series-x/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://upnewsinfo.com/wp-content/uploads/2020/05/linkedin_banner_image_1-Copy-300x150.png"></span><meta itemprop="name" content="Up News Info"></span><meta itemprop="headline " content="The Best Indie Games for Xbox Series X"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://upnewsinfo.com/wp-content/uploads/2021/01/The-Best-Indie-Games-for-Xbox-Series-X.jpg"><meta itemprop="width" content="1200"><meta itemprop="height" content="628"></span></footer></article><div class="td_block_wrap td_block_related_posts tdi_2_fff td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_2_fff" ><script>var block_tdi_2_fff = new tdBlock();
block_tdi_2_fff.id = "tdi_2_fff";
block_tdi_2_fff.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_2_fff","td_column_number":3,"live_filter_cur_post_id":774396,"live_filter_cur_post_author":"12","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2_fff","tdc_css_class_style":"tdi_2_fff_rand_style"}';
block_tdi_2_fff.td_column_number = "3";
block_tdi_2_fff.block_type = "td_block_related_posts";
block_tdi_2_fff.post_count = "3";
block_tdi_2_fff.found_posts = "20437";
block_tdi_2_fff.header_color = "";
block_tdi_2_fff.ajax_pagination_infinite_stop = "";
block_tdi_2_fff.max_num_pages = "6813";
tdBlocksArray.push(block_tdi_2_fff);</script><h4 class="td-related-title td-block-title"><a id="tdi_3_070" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2_fff" href="#">RELATED ARTICLES</a><a id="tdi_4_0f0" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2_fff" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2_fff class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://upnewsinfo.com/2021/01/05/nyse-says-it-no-longer-plans-to-delist-china-mobile-china-telecom-and-china-unicom-but-will-continue-to-evaluate-applicability-of-an-us-eo-to-the-companies-rebecca-falconer-axios/" rel="bookmark" class="td-image-wrap" title="NYSE says it no longer plans to delist China Mobile, China Telecom, and China Unicom, but will continue to evaluate applicability of an US EO to the companies (Rebecca Falconer/Axios)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" data-type="image_tag" data-img-url="https://upnewsinfo.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png"  width="218" height="150" /></a></div> <a href="https://upnewsinfo.com/category/technology/" class="td-post-category">Technology</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://upnewsinfo.com/2021/01/05/nyse-says-it-no-longer-plans-to-delist-china-mobile-china-telecom-and-china-unicom-but-will-continue-to-evaluate-applicability-of-an-us-eo-to-the-companies-rebecca-falconer-axios/" rel="bookmark" title="NYSE says it no longer plans to delist China Mobile, China Telecom, and China Unicom, but will continue to evaluate applicability of an US EO to the companies (Rebecca Falconer/Axios)">NYSE says it no longer plans to delist China Mobile, China Telecom, and China Unicom, but will continue to evaluate applicability of an US...</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://upnewsinfo.com/2021/01/05/xiaomi-mi-10i-launch-in-india-today-watch-event-live-stream-expected-price-and-other-specs-latest-news/" rel="bookmark" class="td-image-wrap" title="Xiaomi Mi 10i launch in India today: Watch event live stream, expected price and other specs &#8211; Latest News"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Xiaomi Mi 10i launch in India today: Watch event live stream, expected price and other specs - Latest News" title="Xiaomi Mi 10i launch in India today: Watch event live stream, expected price and other specs &#8211; Latest News" data-type="image_tag" data-img-url="https://upnewsinfo.com/wp-content/uploads/2021/01/Xiaomi-Mi-10i-launch-in-India-today-Watch-event-live.cms-218x150.jpeg"  width="218" height="150" /></a></div> <a href="https://upnewsinfo.com/category/technology/" class="td-post-category">Technology</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://upnewsinfo.com/2021/01/05/xiaomi-mi-10i-launch-in-india-today-watch-event-live-stream-expected-price-and-other-specs-latest-news/" rel="bookmark" title="Xiaomi Mi 10i launch in India today: Watch event live stream, expected price and other specs &#8211; Latest News">Xiaomi Mi 10i launch in India today: Watch event live stream, expected price and other specs &#8211; Latest News</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://upnewsinfo.com/2021/01/05/novel-crystal-confines-electrons-to-one-dimension-for-spintronic-applications-sciencedaily/" rel="bookmark" class="td-image-wrap" title="Novel crystal confines electrons to one dimension for spintronic applications &#8212; ScienceDaily"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Important milestone in the creation of a quantum computer -- ScienceDaily" title="Novel crystal confines electrons to one dimension for spintronic applications &#8212; ScienceDaily" data-type="image_tag" data-img-url="https://upnewsinfo.com/wp-content/uploads/2020/12/Important-milestone-in-the-creation-of-a-quantum-computer-200x150.png"  width="200" height="150" /></a></div> <a href="https://upnewsinfo.com/category/technology/" class="td-post-category">Technology</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://upnewsinfo.com/2021/01/05/novel-crystal-confines-electrons-to-one-dimension-for-spintronic-applications-sciencedaily/" rel="bookmark" title="Novel crystal confines electrons to one dimension for spintronic applications &#8212; ScienceDaily">Novel crystal confines electrons to one dimension for spintronic applications &#8212; ScienceDaily</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_2_fff" data-td_block_id="tdi_2_fff"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_2_fff" data-td_block_id="tdi_2_fff"><i class="td-icon-font td-icon-menu-right"></i></a></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-footer-container"><ul id="menu-footer" class="td-subfooter-menu"><li id="menu-item-155" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-155"><a href="http://upnewsinfo.com/">Home</a></li><li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-156"><a href="https://upnewsinfo.com/about-us/">About Us</a></li><li id="menu-item-157" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-157"><a href="https://upnewsinfo.com/contact-us/">Contact us</a></li><li id="menu-item-158" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-158"><a href="https://upnewsinfo.com/disclaimer/">Disclaimer</a></li><li id="menu-item-160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-160"><a href="https://upnewsinfo.com/privacy-policy/">Privacy Policy</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy;</div></div></div></div></div><div id="M587632ScriptRootC920162"></div> <script src="https://jsc.mgid.com/u/p/upnewsinfo.com.920162.js" async></script> 
 <script type="text/javascript">var infolinks_pid = 3253680; 
    var infolinks_plugin_version = "WP_3.2.3"; 
    var infolinks_resources = "https://resources.infolinks.com/js";</script> <script type="text/javascript" src="https://resources.infolinks.com/js/infolinks_main.js" ></script>  <script type='text/javascript' src='https://upnewsinfo.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script> <script type='text/javascript' src='https://upnewsinfo.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=c8cba5620a72d5b299fa8f62aeca6adf' id='tdb_js_posts_autoload-js'></script> <script type='text/javascript' src='https://upnewsinfo.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.1' id='td-site-min-js'></script> <script type='text/javascript' src='https://upnewsinfo.com/wp-includes/js/comment-reply.min.js?ver=5.6' id='comment-reply-js'></script> <script type='text/javascript' src='https://upnewsinfo.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=c8cba5620a72d5b299fa8f62aeca6adf' id='tdb_js_files_for_front-js'></script> <script type='text/javascript' src='https://upnewsinfo.com/wp-includes/js/wp-embed.min.js?ver=5.6' id='wp-embed-js'></script>  <script></script> </body></html>