<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US"> <!--<![endif]--><head><style type="text/css" media="all">img.wp-smiley,img.emoji{display:inline !important;border:0 !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-.1em !important;background:none !important;padding:0 !important}</style><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_e1bf1434d8b585a578f2504814d490a0.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_9e7793165b139ec2724eae9948b218db.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_8f7651f15cf1ffb98472eed10c4057dd.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_9423496f0119cfedfd12c89343cb3364.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_f5afb1c7f992cd569e18ed7415ef6231.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_f570ad2fce6a6ff69fcc9b92b2b73a17.css" rel="stylesheet" /><style type="text/css" media="all">@media(max-width:767px){.td-header-desktop-wrap{display:none}}@media(min-width:767px){.td-header-mobile-wrap{display:none}}</style><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_2eec3ff9a11626493acb762c87c6bdb4.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_f98041b16d52288dff543ab9ff880994.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_3b366da54f1b8e4bc8659f11a22d7ed5.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_f66f572c1f47d9b6b1cf8ea50f0968dd.css" rel="stylesheet" /><style type="text/css" media="all"></style><style type="text/css" media="all">.tdi_2_57e{min-height:0}.td-header-mobile-sticky-wrap.td-header-active{opacity:1}@media(max-width:767px){.tdi_2_57e{position:relative}}</style><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_975963178fc93cf6e7a47e8bff4d5976.css" rel="stylesheet" /><style type="text/css" media="all">.tdi_4_bf6{min-height:0}@media(max-width:767px){@media(min-width:768px){.tdi_4_bf6{margin-left:0;margin-right:0}.tdi_4_bf6 .vc_column{padding-left:0;padding-right:0}}}</style><style type="text/css" media="all">.tdi_6_272{vertical-align:baseline}@media(max-width:767px){.tdi_6_272{vertical-align:middle}}@media(max-width:767px){.tdi_6_272{width:20% !important;display:inline-block !important}}</style><style type="text/css" media="all">@media(max-width:767px){.tdi_7_6b0{margin-left:-13px !important}}</style><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_2952dd92bb0478fca32fcd11e4601005.css" rel="stylesheet" /><style type="text/css" media="all">.tdi_9_b0f{vertical-align:baseline}@media(max-width:767px){.tdi_9_b0f{vertical-align:middle}}@media(max-width:767px){.tdi_9_b0f{width:60% !important;display:inline-block !important}}</style><style type="text/css" media="all">.tdi_11_070{vertical-align:baseline}@media(max-width:767px){.tdi_11_070{vertical-align:middle}}@media(max-width:767px){.tdi_11_070{width:20% !important;display:inline-block !important}}</style><style type="text/css" media="all">@media(max-width:767px){.tdi_12_062{margin-right:-19px !important;margin-bottom:0 !important}}</style><style type="text/css" media="all">.tdi_12_062{display:inline-block;float:right;clear:none}.tdi_12_062 .tdb-header-search-button-mob i{font-size:22px;width:55px;height:55px;line-height:55px}.tdi_12_062 .tdb-header-search-button-mob{color:#fff}</style><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_c01b4c38990723477f035702cd604c7b.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_7906b2b74ff1b483d4b1d316e09067fd.css" rel="stylesheet" /><style type="text/css" media="all">.tdi_16_e1b{min-height:0}@media(max-width:767px){@media(min-width:768px){.tdi_16_e1b{margin-left:0;margin-right:0}.tdi_16_e1b .vc_column{padding-left:0;padding-right:0}}}</style><style type="text/css" media="all">.tdi_18_500{vertical-align:baseline}@media(max-width:767px){.tdi_18_500{vertical-align:middle}}@media(max-width:767px){.tdi_18_500{width:20% !important;display:inline-block !important}}</style><style type="text/css" media="all">@media(max-width:767px){.tdi_19_6e0{margin-left:-13px !important}}</style><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_7094a390a3f72b69a1382ddc1105e16d.css" rel="stylesheet" /><style type="text/css" media="all">.tdi_21_7ed{vertical-align:baseline}@media(max-width:767px){.tdi_21_7ed{vertical-align:middle}}@media(max-width:767px){.tdi_21_7ed{width:60% !important;display:inline-block !important}}</style><style type="text/css" media="all">.tdi_23_d25{vertical-align:baseline}@media(max-width:767px){.tdi_23_d25{vertical-align:middle}}@media(max-width:767px){.tdi_23_d25{width:20% !important;display:inline-block !important}}</style><style type="text/css" media="all">@media(max-width:767px){.tdi_24_dd6{margin-right:-19px !important;margin-bottom:0 !important}}</style><style type="text/css" media="all">.tdi_24_dd6{display:inline-block;float:right;clear:none}.tdi_24_dd6 .tdb-header-search-button-mob i{font-size:22px;width:55px;height:55px;line-height:55px}.tdi_24_dd6 .tdb-header-search-button-mob{color:#fff}</style><style type="text/css" media="all">.tdi_26_7e2{min-height:0}.td-header-desktop-wrap{position:relative}.tdi_26_7e2{position:relative}</style><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_eeca333cc799e3917b4fc650b0bedbdd.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_85fe69c6d1dbdafa05a78058e0987f61.css" rel="stylesheet" /><style type="text/css" media="all">.tdi_30_1ed{vertical-align:baseline}.tdi_30_1ed{width:18% !important}@media(min-width:768px) and (max-width:1018px){.tdi_30_1ed{width:20% !important}}</style><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_aced4c138356a86d1fbfae3191c94b28.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_34eefa564bfdc6af58fa10cca616b46c.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_f496148ef390c22f76965d60d42f54e0.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_e45d65dcdd2d67addc4f2a9c3ac78f8e.css" rel="stylesheet" /><style type="text/css" media="all">.tdi_37_476{vertical-align:baseline}.tdi_37_476{width:6% !important}</style><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_dd5c1ad0c1dc813973b6fcd7bb910515.css" rel="stylesheet" /><style type="text/css" media="all">@media(min-width:1141px){.tdi_39_eeb{display:none !important}}@media(min-width:1019px) and (max-width:1140px){.tdi_39_eeb{display:none !important}}@media(min-width:768px) and (max-width:1018px){.tdi_39_eeb{display:none !important}}</style><style type="text/css" media="all">.tdi_39_eeb i{font-size:50px;text-align:center;width:80px;height:80px;line-height:80px;position:relative;top:0}</style><style type="text/css" media="all">.tdi_40_e5d{-webkit-transition:all .2s ease;-moz-transition:all .2s ease;-o-transition:all .2s ease;transition:all .2s ease}.tdi_40_e5d:before{-webkit-transition:all .2s ease;-moz-transition:all .2s ease;-o-transition:all .2s ease;transition:all .2s ease}</style><style type="text/css" media="all">.tdi_42_ee2{margin-bottom:0 !important}</style><style type="text/css" media="all">.td-ht-fast-news-menu .tdb-menu>li>a .tdb-menu-item-text i{position:relative;top:-1px;font-size:28px;margin-right:8px;line-height:1;text-align:center;display:inline-block;vertical-align:middle}</style><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_ee717fce7348b40f4ab8a3b594e10856.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_c3f231642393b7d4bc5cb045bba89e60.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_24222f8e8c5ca971d2691096b884c8d6.css" rel="stylesheet" /><style type="text/css" media="all">.tdi_48_667{vertical-align:baseline}.tdi_48_667{width:12% !important}@media(min-width:768px) and (max-width:1018px){.tdi_48_667{width:20% !important}}</style><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_f8c6eee65c01f638dd19b487627e7507.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_a757698f8eea583c6a5a257b5e4d1402.css" rel="stylesheet" /><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_929ff9bc60f64f1ffc78e2c11bb544c6.css" rel="stylesheet" /><style type="text/css" media="all"></style><style type="text/css" media="all">.tdi_55_753{vertical-align:baseline}.tdi_55_753{width:6% !important}</style><link type="text/css" media="all" href="https://upnewsinfo.com/wp-content/cache/breeze-minification/css/breeze_60255273f62087cdb0657f22aea0feea.css" rel="stylesheet" /><style type="text/css" media="all">@media(min-width:1141px){.tdi_57_725{display:none !important}}@media(min-width:1019px) and (max-width:1140px){.tdi_57_725{display:none !important}}@media(min-width:768px) and (max-width:1018px){.tdi_57_725{display:none !important}}</style><style type="text/css" media="all">.tdi_57_725 i{font-size:50px;text-align:center;width:80px;height:80px;line-height:80px;position:relative;top:0}</style><style type="text/css" media="all">.tdi_58_72b{-webkit-transition:all .2s ease;-moz-transition:all .2s ease;-o-transition:all .2s ease;transition:all .2s ease}.tdi_58_72b:before{-webkit-transition:all .2s ease;-moz-transition:all .2s ease;-o-transition:all .2s ease;transition:all .2s ease}</style><style type="text/css" media="all">.tdi_60_b76{margin-bottom:0 !important}</style><style type="text/css" media="all">.td-ht-fast-news-menu .tdb-menu>li>a .tdb-menu-item-text i{position:relative;top:-1px;font-size:28px;margin-right:8px;line-height:1;text-align:center;display:inline-block;vertical-align:middle}</style><title>John Legend and more honor the late Nipsey Hussle at the 2020 Grammys | Up News Info</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://upnewsinfo.com/xmlrpc.php" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Up News Info &raquo; Feed" href="https://upnewsinfo.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Up News Info &raquo; Comments Feed" href="https://upnewsinfo.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Up News Info &raquo; John Legend and more honor the late Nipsey Hussle at the 2020 Grammys Comments Feed" href="https://upnewsinfo.com/2020/01/26/john-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys/feed/" /><link crossorigin="anonymous" rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Montserrat%3A400%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;display=swap&#038;ver=10.1' type='text/css' media='all' /><link rel='https://api.w.org/' href='https://upnewsinfo.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://upnewsinfo.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://upnewsinfo.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Demi Lovato makes an emotional return, Tyler, the creator wins the first Grammy' href='https://upnewsinfo.com/2020/01/26/demi-lovato-makes-an-emotional-return-tyler-the-creator-wins-the-first-grammy/' /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='https://upnewsinfo.com/?p=143044' /><link rel="alternate" type="application/json+oembed" href="https://upnewsinfo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fupnewsinfo.com%2F2020%2F01%2F26%2Fjohn-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys%2F" /><link rel="alternate" type="text/xml+oembed" href="https://upnewsinfo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fupnewsinfo.com%2F2020%2F01%2F26%2Fjohn-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.1.4" />  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-156330652-1"></script> <meta name="google-site-verification" content="avGZF9DeDQwSth6p_JJ1lC1Z5faKIE3TGp16d1sS8I0" /><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--><link rel="amphtml" href="https://upnewsinfo.com/2020/01/26/john-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys/?amp"> <script type="application/ld+json">{
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://upnewsinfo.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://upnewsinfo.com/category/entertainment/",
                    "name": "Entertainment"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://upnewsinfo.com/2020/01/26/john-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys/",
                    "name": "John Legend and more honor the late Nipsey Hussle at the 2020..."                                
                }
            }    
        ]
    }</script> <link rel="icon" href="https://upnewsinfo.com/wp-content/uploads/2019/10/cropped-512x5112-upnews-32x32.png" sizes="32x32" /><link rel="icon" href="https://upnewsinfo.com/wp-content/uploads/2019/10/cropped-512x5112-upnews-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://upnewsinfo.com/wp-content/uploads/2019/10/cropped-512x5112-upnews-180x180.png" /><meta name="msapplication-TileImage" content="https://upnewsinfo.com/wp-content/uploads/2019/10/cropped-512x5112-upnews-270x270.png" /> <script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_6b62e2868214da43a064030d8ecc923c.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_49edccea2e7ba985cadc9ba0531cbed1.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_fd4f55c9870d593283254c723fe7b003.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_de774c650ba4b80a6283c2178fddc88c.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_54ac221826ae07a93bee8084d8df30fb.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_6783dd3c42f32314b3b6f921b4ba467b.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_25f45b6e9f56c2aea6d5715c1f86a5ef.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_c52c4ccfc7387b0ee3bfb9c6bec37129.js"></script></head><body class="post-template-default single single-post postid-143044 single-format-standard td-standard-pack john-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys global-block-template-1  tdc-header-template td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Vimeo"> <i class="td-icon-font td-icon-vimeo"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="VKontakte"> <i class="td-icon-font td-icon-vk"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-menu-login-section"><div class="td-guest-wrap"><div class="td-menu-login"><a id="login-link-mob">Sign in</a></div></div></div><div class="td-mobile-content"><div class="menu-primary-container"><ul id="menu-primary" class="td-mobile-main-menu"><li id="menu-item-511" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first menu-item-511"><a href="https://upnewsinfo.com/category/entertainment/">Entertainment</a></li><li id="menu-item-436" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-436"><a href="https://upnewsinfo.com/category/technology/">Technology</a></li><li id="menu-item-516" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-516"><a href="https://upnewsinfo.com/category/sports/">Sports</a></li><li id="menu-item-438" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-438"><a href="https://upnewsinfo.com/category/healthcare/">Healthcare</a></li><li id="menu-item-437" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437"><a href="https://upnewsinfo.com/category/business/">Business</a></li><li id="menu-item-435" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-435"><a href="https://upnewsinfo.com/category/financial/">Financial</a></li></ul></div></div></div><div id="login-form-mobile" class="td-register-section"><div id="td-login-mob" class="td-login-animation td-login-hide-mob"><div class="td-login-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign in</div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-login-form-wrap"><div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div><div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div> <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN"><div class="td-login-info-text"> <a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div><div class="td-login-register-link"></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://upnewsinfo.com/privacy-policy/">Privacy Policy</a></div></div></div><div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob"><div class="td-forgot-pass-close"> <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Password recovery</div></div><div class="td-login-form-wrap"><div class="td-login-panel-title">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div> <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass"></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://upnewsinfo.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="td-header-template-wrap" style="position: relative"><div class="td-header-mobile-wrap "><div id="tdi_1_eef" class="tdc-zone"><div class="tdc_zone tdi_2_57e  wpb_row td-pb-row tdc-element-style" data-sticky-offset="0" ><div class="tdi_1_eef_rand_style td-element-style" ></div><div id="tdi_3_eeb" class="tdc-row"><div class="vc_row tdi_4_bf6  wpb_row td-pb-row" ><div class="vc_column tdi_6_272  wpb_column vc_column_container tdc-column td-pb-span4"><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_menu tdi_7_6b0 td-pb-border-top td_block_template_1 tdb-header-align"  data-td-block-uid="tdi_7_6b0" ><div class="tdb-block-inner td-fix-index"><a class="tdb-mobile-menu-button" href="#"><i class="tdb-mobile-menu-icon td-icon-mobile"></i></a></div></div></div></div><div class="vc_column tdi_9_b0f  wpb_column vc_column_container tdc-column td-pb-span4"><div class="wpb_wrapper"></div></div><div class="vc_column tdi_11_070  wpb_column vc_column_container tdc-column td-pb-span4"><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_search tdi_12_062 td-pb-border-top td_block_template_1 tdb-header-align"  data-td-block-uid="tdi_12_062" ><div class="tdb-block-inner td-fix-index"><a class="tdb-header-search-button-mob dropdown-toggle" href="#" role="button" data-toggle="dropdown"><i class="tdb-mobile-search-icon td-icon-search"></i></a></div></div></div></div></div></div></div></div></div><div class="td-header-mobile-sticky-wrap tdc-zone-sticky-invisible tdc-zone-sticky-inactive" style="display: none"><div id="tdi_13_e0e" class="tdc-zone"><div class="tdc_zone tdi_14_506  wpb_row td-pb-row tdc-element-style td-header-sticky-smart" data-sticky-offset="0" ><div class="tdi_13_e0e_rand_style td-element-style" ></div><div id="tdi_15_555" class="tdc-row"><div class="vc_row tdi_16_e1b  wpb_row td-pb-row" ><div class="vc_column tdi_18_500  wpb_column vc_column_container tdc-column td-pb-span4"><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_menu tdi_19_6e0 td-pb-border-top td_block_template_1 tdb-header-align"  data-td-block-uid="tdi_19_6e0" ><div class="tdb-block-inner td-fix-index"><a class="tdb-mobile-menu-button" href="#"><i class="tdb-mobile-menu-icon td-icon-mobile"></i></a></div></div></div></div><div class="vc_column tdi_21_7ed  wpb_column vc_column_container tdc-column td-pb-span4"><div class="wpb_wrapper"></div></div><div class="vc_column tdi_23_d25  wpb_column vc_column_container tdc-column td-pb-span4"><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_search tdi_24_dd6 td-pb-border-top td_block_template_1 tdb-header-align"  data-td-block-uid="tdi_24_dd6" ><div class="tdb-block-inner td-fix-index"><a class="tdb-header-search-button-mob dropdown-toggle" href="#" role="button" data-toggle="dropdown"><i class="tdb-mobile-search-icon td-icon-search"></i></a></div></div></div></div></div></div></div></div></div><div class="td-header-desktop-wrap "><div id="tdi_25_972" class="tdc-zone"><div class="tdc_zone tdi_26_7e2  wpb_row td-pb-row tdc-element-style"  ><div class="tdi_25_972_rand_style td-element-style" ></div><div id="tdi_27_2e8" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_28_ee0  wpb_row td-pb-row tdc-row-content-vert-center" ><div class="vc_column tdi_30_1ed  wpb_column vc_column_container tdc-column td-pb-span3"><div class="wpb_wrapper"></div></div><div class="vc_column tdi_32_1d5  wpb_column vc_column_container tdc-column td-pb-span6"><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_menu tdi_33_b6b tds_menu_active1 tds_menu_sub_active1 tdb-menu-items-in-more tdb-mm-align-screen td-pb-border-top td-ht-fast-news-menu td_block_template_1 tdb-header-align"  data-td-block-uid="tdi_33_b6b"  style=" z-index: 999;"><div id=tdi_33_b6b class="td_block_inner td-fix-index"><div class="tdb-menu-items-pulldown tdb-menu-items-pulldown-inactive"><ul id="menu-primary-1" class="tdb-block-menu tdb-menu tdb-menu-items-visible"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent tdb-cur-menu-item menu-item-first tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-511"><a href="https://upnewsinfo.com/category/entertainment/">Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-436"><a href="https://upnewsinfo.com/category/technology/">Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-516"><a href="https://upnewsinfo.com/category/sports/">Sports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-438"><a href="https://upnewsinfo.com/category/healthcare/">Healthcare</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-437"><a href="https://upnewsinfo.com/category/business/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-435"><a href="https://upnewsinfo.com/category/financial/">Financial</a></li></ul><div class="tdb-menu-items-dropdown"><div class="td-subcat-more"><div class="tdb-menu-item-text">More</div><i class="tdb-menu-more-subicon td-icon-down"></i><ul class="td-pulldown-filter-list"></ul></div></div></div></div></div></div></div><div class="vc_column tdi_37_476  wpb_column vc_column_container tdc-column td-pb-span3"><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_search tdi_38_5dd td-pb-border-top td_block_template_1 tdb-header-align"  data-td-block-uid="tdi_38_5dd" ><div class="tdb-block-inner td-fix-index"><div class="tdb-drop-down-search" aria-labelledby="td-header-search-button"><div class="tdb-drop-down-search-inner"><form method="get" class="tdb-search-form" action="https://upnewsinfo.com/"><div class="tdb-search-form-inner"><input class="tdb-head-search-form-input" type="text" value="" name="s" autocomplete="off" /><button class="wpb_button wpb_btn-inverse btn tdb-head-search-form-btn" type="submit"><span>Search</span></button></div></form><div class="tdb-aj-search"></div></div></div><a href="#" role="button" class="tdb-head-search-btn dropdown-toggle" data-toggle="dropdown"><i class="tdb-search-icon td-icon-search"></i></a></div></div><div class="tdm_block td_block_wrap tdm_block_icon tdi_39_eeb tdm-content-horiz-left td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_39_eeb"   ><i class="tds-icon tdc-font-tdmp tdc-font-tdmp-globe tdi_40_e5d td-fix-index"></i></div><div class="wpb_wrapper td_block_wrap vc_raw_html tdi_42_ee2 "><div class="td-fix-index"></div></div></div></div></div></div></div></div></div><div class="td-header-desktop-sticky-wrap tdc-zone-sticky-invisible tdc-zone-sticky-inactive" style="display: none"><div id="tdi_43_be6" class="tdc-zone"><div class="tdc_zone tdi_44_9d2  wpb_row td-pb-row tdc-element-style td-header-sticky-smart" data-sticky-offset="0" ><div class="tdi_43_be6_rand_style td-element-style" ></div><div id="tdi_45_e02" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_46_767  wpb_row td-pb-row tdc-row-content-vert-center" ><div class="vc_column tdi_48_667  wpb_column vc_column_container tdc-column td-pb-span3"><div class="wpb_wrapper"></div></div><div class="vc_column tdi_50_250  wpb_column vc_column_container tdc-column td-pb-span6"><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_menu tdi_51_57b tds_menu_active1 tds_menu_sub_active1 tdb-menu-items-in-more tdb-mm-align-screen td-pb-border-top td-ht-fast-news-menu td_block_template_1 tdb-header-align"  data-td-block-uid="tdi_51_57b"  style=" z-index: 999;"><div id=tdi_51_57b class="td_block_inner td-fix-index"><div class="tdb-menu-items-pulldown tdb-menu-items-pulldown-inactive"><ul id="menu-primary-2" class="tdb-block-menu tdb-menu tdb-menu-items-visible"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent tdb-cur-menu-item menu-item-first tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-511"><a href="https://upnewsinfo.com/category/entertainment/">Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-436"><a href="https://upnewsinfo.com/category/technology/">Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-516"><a href="https://upnewsinfo.com/category/sports/">Sports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-438"><a href="https://upnewsinfo.com/category/healthcare/">Healthcare</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-437"><a href="https://upnewsinfo.com/category/business/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-435"><a href="https://upnewsinfo.com/category/financial/">Financial</a></li></ul><div class="tdb-menu-items-dropdown"><div class="td-subcat-more"><div class="tdb-menu-item-text">More</div><i class="tdb-menu-more-subicon td-icon-down"></i><ul class="td-pulldown-filter-list"></ul></div></div></div></div></div></div></div><div class="vc_column tdi_55_753  wpb_column vc_column_container tdc-column td-pb-span3"><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_search tdi_56_61e td-pb-border-top td_block_template_1 tdb-header-align"  data-td-block-uid="tdi_56_61e" ><div class="tdb-block-inner td-fix-index"><div class="tdb-drop-down-search" aria-labelledby="td-header-search-button"><div class="tdb-drop-down-search-inner"><form method="get" class="tdb-search-form" action="https://upnewsinfo.com/"><div class="tdb-search-form-inner"><input class="tdb-head-search-form-input" type="text" value="" name="s" autocomplete="off" /><button class="wpb_button wpb_btn-inverse btn tdb-head-search-form-btn" type="submit"><span>Search</span></button></div></form><div class="tdb-aj-search"></div></div></div><a href="#" role="button" class="tdb-head-search-btn dropdown-toggle" data-toggle="dropdown"><i class="tdb-search-icon td-icon-search"></i></a></div></div><div class="tdm_block td_block_wrap tdm_block_icon tdi_57_725 tdm-content-horiz-left td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_57_725"   ><i class="tds-icon tdc-font-tdmp tdc-font-tdmp-globe tdi_58_72b td-fix-index"></i></div><div class="wpb_wrapper td_block_wrap vc_raw_html tdi_60_b76 "><div class="td-fix-index"></div></div></div></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-default "><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://upnewsinfo.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Entertainment" class="entry-crumb" href="https://upnewsinfo.com/category/entertainment/">Entertainment</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">John Legend and more honor the late Nipsey Hussle at the 2020...</span></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-143044" class="post-143044 post type-post status-publish format-standard has-post-thumbnail category-entertainment" itemscope itemtype="https://schema.org/Article"47><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a  href="https://upnewsinfo.com/category/entertainment/">Entertainment</a></li></ul><header class="td-post-title"><h1 class="entry-title">John Legend and more honor the late Nipsey Hussle at the 2020 Grammys</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://upnewsinfo.com/author/bradley-lamb/">Bradley Lamb</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-26T23:00:25+00:00" >January 26, 2020</time></span><div class="td-post-comments"><a href="https://upnewsinfo.com/2020/01/26/john-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys/#respond"><i class="td-icon-comments"></i>0</a></div><div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-143044">1</span></div></div></header></div><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text"><div class="td-social-but-icon"><i class="td-icon-share"></i></div><div class="td-social-but-text">Share</div></div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fupnewsinfo.com%2F2020%2F01%2F26%2Fjohn-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=John+Legend+and+more+honor+the+late+Nipsey+Hussle+at+the+2020+Grammys&url=https%3A%2F%2Fupnewsinfo.com%2F2020%2F01%2F26%2Fjohn-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys%2F&via=Up+News+Info"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://upnewsinfo.com/2020/01/26/john-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys/&amp;media=https://upnewsinfo.com/wp-content/uploads/2020/01/John-Legend-and-more-honor-the-late-Nipsey-Hussle-at.jpg&description=John+Legend+and+more+honor+the+late+Nipsey+Hussle+at+the+2020+Grammys"><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=John+Legend+and+more+honor+the+late+Nipsey+Hussle+at+the+2020+Grammys %0A%0A https://upnewsinfo.com/2020/01/26/john-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><div class="td-post-featured-image"><a href="https://upnewsinfo.com/wp-content/uploads/2020/01/John-Legend-and-more-honor-the-late-Nipsey-Hussle-at.jpg" data-caption=""><img width="600" height="600" class="entry-thumb td-modal-image" src="https://upnewsinfo.com/wp-content/uploads/2020/01/John-Legend-and-more-honor-the-late-Nipsey-Hussle-at.jpg" srcset="https://upnewsinfo.com/wp-content/uploads/2020/01/John-Legend-and-more-honor-the-late-Nipsey-Hussle-at.jpg 600w, https://upnewsinfo.com/wp-content/uploads/2020/01/John-Legend-and-more-honor-the-late-Nipsey-Hussle-at-300x300.jpg 300w, https://upnewsinfo.com/wp-content/uploads/2020/01/John-Legend-and-more-honor-the-late-Nipsey-Hussle-at-150x150.jpg 150w, https://upnewsinfo.com/wp-content/uploads/2020/01/John-Legend-and-more-honor-the-late-Nipsey-Hussle-at-420x420.jpg 420w" sizes="(max-width: 600px) 100vw, 600px" alt="<pre><pre>John Legend and more honor the late Nipsey Hussle at the 2020 Grammys

" title="John Legend and more honor the late Nipsey Hussle at"/></a></div>
            <div id="video-int-txt-0" data-hook="scrollable-block">
<section data-textblock-tracking="text-block-video-text" data-swiftype-index="false">
<p>Rest in power.</p>
<p>Sunday at the 2020 Grammy Awards, <strong>Nipsey Hussle</strong>born<strong> Ermias Joseph Asghedom,</strong> was honored by <strong>John Legend, 1500 or Nothin &amp; # 39 ;, DJ Khaled, Roddy Ricch, Kirk Franklin, Meek Mill </strong>Y <strong>Yg</strong> to celebrate the life of the talented rapper, entrepreneur and activist.</p>
<p>director <strong>Ava DuVernay</strong>He introduced the artists before they launched into rap recognizing his friend and only some of his incredible achievements.</p>
<p>Legend and Khaled then released their song &quot;Higher,quot;, which they had recorded with the deceased artist shortly before his premature death.</p>
<p>At the end of their moving performance, Hussle&#39;s face appeared on the screen behind them next to them. <strong>Kobe Bryant</strong>, who had tragically died at the beginning of the day in a helicopter accident that also killed his 13-year-old daughter, <strong>Gianna</strong>.</p>
<p>&quot;Long live Nip, long live Kobe,&quot; Khaled added.</p>
<p>Hussle, who was tragically killed last March, had also won posthumously Best rap performance for &quot;Racks in the Middle,quot; at the beginning of the day.</p>
</p>
</section></div>
<div id="text-2" data-hook="scrollable-block">
<section data-textblock-tracking="text-block-text-only" data-swiftype-index="false">
<p>Your lifelong partner <strong>Lauren London</strong> He accepted the coveted trophy for him and said: &quot;I speak on behalf of our family and in honor of Nip, who was a phenomenal recipient &#8230; God allowed him to use this music to tell his truth, give his wisdom and something we will do.&quot; forever to live. &quot;</p>
<p>Hussle&#39;s grandmother <strong>Margaret Boutte</strong> He was also present and added: &quot;I wanted to thank everyone for showing all the love I have felt for him all his life and I will always live in my heart. Thank you.&quot;</p>
<p>The moving tribute was one of the best moments of the night and a reminder that, while the late rapper is gone, he will never be forgotten.</p>
</section>
</div>
<div id="tune-in-3" data-hook="scrollable-block">
<p class="tune-in__text" data-swiftype-index="false">For a summary of the Grammy 2020 Awards, don&#39;t miss the <i>ME! After the party</i> Special tonight at 11:30 p.m. ET / 8: 30 p.m. PT. And see <i>ME! News</i> Monday at 7 a.m. for more news from the Grammys!</p>
</div>
<p></pre></pre></div><footer><div class="td-post-source-tags"></div><div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text"><div class="td-social-but-icon"><i class="td-icon-share"></i></div><div class="td-social-but-text">Share</div></div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fupnewsinfo.com%2F2020%2F01%2F26%2Fjohn-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=John+Legend+and+more+honor+the+late+Nipsey+Hussle+at+the+2020+Grammys&url=https%3A%2F%2Fupnewsinfo.com%2F2020%2F01%2F26%2Fjohn-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys%2F&via=Up+News+Info"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://upnewsinfo.com/2020/01/26/john-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys/&amp;media=https://upnewsinfo.com/wp-content/uploads/2020/01/John-Legend-and-more-honor-the-late-Nipsey-Hussle-at.jpg&description=John+Legend+and+more+honor+the+late+Nipsey+Hussle+at+the+2020+Grammys"><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=John+Legend+and+more+honor+the+late+Nipsey+Hussle+at+the+2020+Grammys %0A%0A https://upnewsinfo.com/2020/01/26/john-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://upnewsinfo.com/author/bradley-lamb/">Bradley Lamb</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Bradley Lamb"></span><meta itemprop="datePublished" content="2020-01-26T23:00:25+00:00"><meta itemprop="dateModified" content="2020-01-26T23:00:28+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://upnewsinfo.com/2020/01/26/john-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://upnewsinfo.com/2020/01/26/john-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys/"></span><meta itemprop="name" content="Up News Info"></span><meta itemprop="headline " content="John Legend and more honor the late Nipsey Hussle at the 2020 Grammys"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://upnewsinfo.com/wp-content/uploads/2020/01/John-Legend-and-more-honor-the-late-Nipsey-Hussle-at.jpg"><meta itemprop="width" content="600"><meta itemprop="height" content="600"></span></footer></article><div class="td_block_wrap td_block_related_posts tdi_62_0e2 td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_62_0e2" ><script>var block_tdi_62_0e2 = new tdBlock();
block_tdi_62_0e2.id = "tdi_62_0e2";
block_tdi_62_0e2.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_62_0e2","td_column_number":3,"live_filter_cur_post_id":143044,"live_filter_cur_post_author":"10","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_62_0e2","tdc_css_class_style":"tdi_62_0e2_rand_style"}';
block_tdi_62_0e2.td_column_number = "3";
block_tdi_62_0e2.block_type = "td_block_related_posts";
block_tdi_62_0e2.post_count = "3";
block_tdi_62_0e2.found_posts = "17355";
block_tdi_62_0e2.header_color = "";
block_tdi_62_0e2.ajax_pagination_infinite_stop = "";
block_tdi_62_0e2.max_num_pages = "5785";
tdBlocksArray.push(block_tdi_62_0e2);</script><h4 class="td-related-title td-block-title"><a id="tdi_63_6dd" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_62_0e2" href="#">RELATED ARTICLES</a><a id="tdi_64_f35" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_62_0e2" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_62_0e2 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://upnewsinfo.com/2020/01/26/demi-lovato-makes-an-emotional-return-tyler-the-creator-wins-the-first-grammy/" rel="bookmark" class="td-image-wrap" title="Demi Lovato makes an emotional return, Tyler, the creator wins the first Grammy"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Demi Lovato makes an emotional return, Tyler, the creator wins the first Grammy" title="Demi Lovato makes an emotional return, Tyler, the creator wins the first Grammy" data-type="image_tag" data-img-url="https://upnewsinfo.com/wp-content/uploads/2020/01/1580097324_Demi-Lovato-makes-an-emotional-return-Tyler-the-creator-wins-218x150.jpg"  width="218" height="150" /></a></div> <a href="https://upnewsinfo.com/category/entertainment/" class="td-post-category">Entertainment</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://upnewsinfo.com/2020/01/26/demi-lovato-makes-an-emotional-return-tyler-the-creator-wins-the-first-grammy/" rel="bookmark" title="Demi Lovato makes an emotional return, Tyler, the creator wins the first Grammy">Demi Lovato makes an emotional return, Tyler, the creator wins the first Grammy</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://upnewsinfo.com/2020/01/26/john-legend-meek-mill-and-more-act-up-news-info/" rel="bookmark" class="td-image-wrap" title="John Legend, Meek Mill and more act &#8211; Up News Info"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Nipsey Hussle Tribute" title="John Legend, Meek Mill and more act &#8211; Up News Info" data-type="image_tag" data-img-url="https://upnewsinfo.com/wp-content/uploads/2020/01/John-Legend-Meek-Mill-and-more-act-Up-News-218x150.jpg"  width="218" height="150" /></a></div> <a href="https://upnewsinfo.com/category/entertainment/" class="td-post-category">Entertainment</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://upnewsinfo.com/2020/01/26/john-legend-meek-mill-and-more-act-up-news-info/" rel="bookmark" title="John Legend, Meek Mill and more act &#8211; Up News Info">John Legend, Meek Mill and more act &#8211; Up News Info</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://upnewsinfo.com/2020/01/26/bts-and-more-join-lil-nas-x-and-billy-ray-cyrus-on-the-grammys-stage/" rel="bookmark" class="td-image-wrap" title="BTS and more join Lil Nas X and Billy Ray Cyrus on the Grammys stage"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="BTS and more join Lil Nas X and Billy Ray Cyrus on the Grammys stage" title="BTS and more join Lil Nas X and Billy Ray Cyrus on the Grammys stage" data-type="image_tag" data-img-url="https://upnewsinfo.com/wp-content/uploads/2020/01/1580097144_BTS-and-more-join-Lil-Nas-X-and-Billy-Ray-218x150.jpg"  width="218" height="150" /></a></div> <a href="https://upnewsinfo.com/category/entertainment/" class="td-post-category">Entertainment</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://upnewsinfo.com/2020/01/26/bts-and-more-join-lil-nas-x-and-billy-ray-cyrus-on-the-grammys-stage/" rel="bookmark" title="BTS and more join Lil Nas X and Billy Ray Cyrus on the Grammys stage">BTS and more join Lil Nas X and Billy Ray Cyrus on the Grammys stage</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_62_0e2" data-td_block_id="tdi_62_0e2"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_62_0e2" data-td_block_id="tdi_62_0e2"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="comments" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/01/26/john-legend-and-more-honor-the-late-nipsey-hussle-at-the-2020-grammys/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://upnewsinfo.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div><div class="comment-form-input-wrap td-form-comment"><textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea><div class="td-warning-comment">Please enter your comment!</div></div><div class="comment-form-input-wrap td-form-author"> <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' /><div class="td-warning-author">Please enter your name here</div></div><div class="comment-form-input-wrap td-form-email"> <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' /><div class="td-warning-email-error">You have entered an incorrect email address!</div><div class="td-warning-email">Please enter your email address here</div></div><div class="comment-form-input-wrap td-form-url"> <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" /></div><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='143044' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-footer-container"><ul id="menu-footer" class="td-subfooter-menu"><li id="menu-item-155" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-155"><a href="https://upnewsinfo.com/">Home</a></li><li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-156"><a href="https://upnewsinfo.com/about-us/">About Us</a></li><li id="menu-item-157" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-157"><a href="https://upnewsinfo.com/contact-us/">Contact us</a></li><li id="menu-item-158" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-158"><a href="https://upnewsinfo.com/disclaimer/">Disclaimer</a></li><li id="menu-item-160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-160"><a href="https://upnewsinfo.com/privacy-policy/">Privacy Policy</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy;</div></div></div></div></div> <script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_8e6d3e606fdf1dc8e20b28ee8acd14d4.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_fd9ea545dea8f8917563588aa5da7c27.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_0eb7fb3be466db93e8d0ac1e006c1078.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_a66330cfa7553cdd318b2202920c89d9.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_68969a63c8a9dbf7604ca10f8d917826.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_01b4e01b0bc89365631c07c568497934.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_aa75536f9091cf931e8364dfcf19e23a.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_a02c3a6134bb45067b185b997ac9942f.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_bd29115fcfbb73b8d0c28a58682f8ffd.js"></script><script type="text/javascript" src="https://upnewsinfo.com/wp-content/cache/breeze-minification/js/breeze_32694cedafdafda0a9da791e4f94d262.js"></script></body></html>
<!-- Cache served by breeze CACHE - Last modified: Mon, 27 Jan 2020 04:01:00 GMT -->
